Задать вопрос
9 февраля, 20:24

Pascal. Построить одномерный массив вещественных чисел. Числа сформировать при помощь генератора случайных чисел

+2
Ответы (2)
  1. 9 февраля, 21:21
    0
    Программа выводит числа в диапазоне [0 ... R)

    Const

    N = 13;

    Var

    A:array[1 ... N] of real;

    i, R:integer;

    Begin

    Write ('R = ') ; ReadLn (R) ;

    For i: = 1 to N do

    Begin

    A[i]:=random () * R;

    Write (A[i]:0:3,' ') ;

    End;

    End.
  2. 9 февраля, 23:28
    0
    Var

    mas:array [1 ... 20] of real;

    i:integer;

    begin

    randomize;

    for i:=1 to 20 do begin

    mas[i]:=random (100) - 70+random (1000) / 1000;

    write (mas[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Построить одномерный массив вещественных чисел. Числа сформировать при помощь генератора случайных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Построить одномерный массив целых чисел, принимающих значения на заданном интервала. Числа сформировать при помощь генератора случайных чисел
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Создать программу. Сформировать массив В (15). состоящий из чисел до 50. Найти сумму элементов этого массива. Массив сформировать при помощи генератора случайных чисел, элементы вывести на экран.
Ответы (1)