Задать вопрос
20 июля, 19:57

Информатика 10 класс

1) Написать функцию, которая выдаёт истину, если число четное и если ложь - нечетное.

2) Написать процедуру, которая заменяет все четные числа в массиве 0 и выводит результат на экран.

+3
Ответы (1)
  1. 20 июля, 20:41
    0
    1) function chet (a:longint) : boolean;

    begin chet: = (a mod 2) = 0; end;

    2) procedure z (var a:array of longint; length:longint) ;

    var i:longint;

    begin

    for i:=1 to length do

    begin

    if not odd (a[i]) then a[i]:=0;

    write (a[i],' ') ;

    end;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика 10 класс 1) Написать функцию, которая выдаёт истину, если число четное и если ложь - нечетное. 2) Написать процедуру, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)
Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия: а) Четные числа делит на 2 и результат выводит на экран б) нечетные числа выводит на экран без изменений
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)