Задать вопрос
15 сентября, 02:25

Реализовать функцию Delete (s, i), возвращающую строку, полученную удалением из строки s всех символов, начиная с i-го. Не использовать стандартную процедуру Delete.

+5
Ответы (1)
  1. 15 сентября, 04:37
    0
    Function Delete (s:string; i:integer) : string;

    begin

    Delete:=Copy (s, 1, i-1)

    end;

    begin

    Writeln (Delete ('Тестовая строка',9))

    end.

    Результат:

    Тестовая
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Реализовать функцию Delete (s, i), возвращающую строку, полученную удалением из строки s всех символов, начиная с i-го. Не использовать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
Ответы (1)
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)
Описать процедуру PowerA3 (A, B), вычисляющую третью степень числа A и возвращающую ее в переменной B (A - входной, B - выходной параметр; оба параметра являются вещественными). С помощью этой процедуры найти третьи степени пяти данных чисел
Ответы (1)