Задать вопрос
13 мая, 06:54

Задана последовательность чисел, оканчивающихся нулем. Найти максимальное значение чисел.

Программирование на языке Паскаль.

+4
Ответы (2)
  1. 13 мая, 07:53
    0
    Мои рассуждения:

    1. Объявить переменные и массив в разделе VAR

    Последовательность чисел заканчивающихся нулем - это массив.

    2. Задать массив и ввести такие числа.

    Найти максимальное значение из таких чисел.

    3. Отсортировать этот массив по возрастанию.

    4. Вывести найденное значение.

    .
  2. 13 мая, 08:53
    0
    Var a, max:integer;

    begin

    read (a) ;

    max:=0;

    while a0 do

    begin

    if a>max then max:=a;

    read (a) ;

    end;

    write (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана последовательность чисел, оканчивающихся нулем. Найти максимальное значение чисел. Программирование на языке Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем. Найти произведение чисел, оканчивающихся цифрой 5.
Ответы (1)
Программирование по информатике С клавиатуры вводится последовательность чисел не превышающих 10000. Найти и вывести максимальное положительное число. Напишите программу на языке паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. На входе непустая последовательность натуральных чисел с нулем в конце. Вывести MIN и среднее арифметическое. Представить блок-схему и pascal-программу. 2. На входе последовательность вещественных чисел с нулем в конце.
Ответы (1)