Задать вопрос
12 мая, 01:06

Все элементы массива с четными номерами, предшествующие первому по порядку максимальному элементу, домножить на этот элемент. (паскаль)

+2
Ответы (1)
  1. 12 мая, 03:58
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, Max:integer;

    Begin

    {Заполнение массива}

    Randomize;

    Write ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (N) ;

    Write (A[i],' ') ;

    End;

    {Поиск максимума}

    Max:=1;

    For i: = 2 to N do

    if A[i]>A[Max] then Max:=i;

    {Домножение}

    For i: = 1 to Max-1 do

    if i mod 2 = 0 then A[i]:=A[i]*A[Max];

    WriteLn;

    WriteLn ('Max = A[', Max,'] = ', A[Max]) ;

    Write ('Переработанный массив: ') ;

    For i: = 1 to N do

    Write (A[i],' ') ;

    End.

    Пример:

    Исходный массив: 3 10 0 5 8 11 9 1 1 12 11 12 7

    Max = A[10] = 12

    Переработанный массив: 3 120 0 60 8 132 9 12 1 12 11 12 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Все элементы массива с четными номерами, предшествующие первому по порядку максимальному элементу, домножить на этот элемент. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)