Задать вопрос
7 февраля, 02:55

С клавиатуры заданы 3 числа, найдите наибольшее из этих чисел, вывести эти числа на экран в порядке убывания

+5
Ответы (1)
  1. 7 февраля, 03:26
    0
    Program n1;

    procedure Sort (var A, B, C: integer) ;

    var t: integer;

    begin

    if A < B then begin

    t : = B;

    B : = A;

    A : = t

    end;

    if A < C then begin

    t : = C;

    C : = A;

    A : = t

    end;

    if B < C then begin

    t : = C;

    C : = B;

    B : = t

    end

    end;

    var

    a, b, c: integer;

    begin

    writeln ('Введите три числа: ') ;

    readln (a, b, c) ;

    Sort (a, b, c) ;

    writeln ('наибольшее: ', a) ;

    writeln ('числа: ', a,' ', b,' ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры заданы 3 числа, найдите наибольшее из этих чисел, вывести эти числа на экран в порядке убывания ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)