Задать вопрос
23 августа, 19:19

На паскале

У второклассников очень популярна следующая задача:

101=1

8181515=4

1111112=0

8888888=14

1010101=3

7000007=?

Преподавателю программирования в некоем Центре для одаренных детей так понравилась эта задачка, что он решил именно ее использовать для проверки знаний математики 2-го класса у своих учеников.

Пусть первое число x, а соответствующее ему n

Входные данные

Единственное неотрицательное число x, не превышающее 101001.

Выходные данные

Выведите n.

+5
Ответы (2)
  1. 23 августа, 22:08
    0
    {тоже как вариант}

    const

    v: array [0 ... 9] of integer = (1,0,0,0,1,0,1,0,2,1) ;

    var

    x, n: integer;

    begin

    read (x) ;

    n : = 0;

    repeat

    n : = n + v[x mod 10];

    x : = x div 10;

    until x = 0;

    write (n)

    end.
  2. 23 августа, 22:22
    0
    Var

    x: string;

    n, i: integer;

    begin

    readln (x) ;

    for i : = 1 to length (x) do

    case x[i] of

    '0', '4', '6', '9': inc (n) ;

    '8': inc (n, 2) ;

    end;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На паскале У второклассников очень популярна следующая задача: 101=1 8181515=4 1111112=0 8888888=14 1010101=3 7000007=? Преподавателю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Отметьте и последовательно соедините на коорд. плоскости точки, координаты которых приведены в двоичной системе счисления: (101,101) (101,101000) (11001,101000) (11001,101) (10100,101) (10100,11110) (1010,11110) (1010,101) (101,101)
Ответы (1)
Напишите программу, вычисляющую 2^N. Входные данные Вводится целое неотрицательное число N, которое не превосходит 30. Выходные данные Выведите число 2^N.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
101011+101001 10101111-111111 расположить числа в порядке возрастания 1010101; 59 (16) ; 130 (8) ; 86 (10) сравните 103 (6) и 160 (4) 402 (6) и 400 (8) 78 (16) и 167 (8) п. с в скобках система счисления.
Ответы (1)