Задать вопрос
8 июня, 05:06

Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!

+1
Ответы (1)
  1. 8 июня, 07:51
    -2
    Var A, N:longint;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    if N mod 2 = 0 then

    Begin

    A:=1;

    While A
    A:=A*2;

    if A=N then Write ('YES')

    else Write ('NO')

    End

    else Write ('NO')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке Паскаль! Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
Ответы (1)
По данному натуральному числу N найдите наибольшую целую степень двойки, не превосходящую N. Выведите показатель степени и саму степень. Операцией возведения в степень пользоваться нельзя! Phyton Цикл While
Ответы (1)
Программа на питоне, помогите) По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания. Операцией возведения в степень пользоваться нельзя! Входные данные Вводится натуральное число.
Ответы (1)
По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания. Операцией возведения в степень пользоваться нельзя!
Ответы (1)
Петя заметил, что сегодня удивительный день: на его флешке все файлы различного объема и размер в килобайтах каждого файла является точной степенью двойки, а всего занято 2017 килобайт.
Ответы (1)