Задать вопрос
26 марта, 08:21

По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

+5
Ответы (1)
  1. 26 марта, 10:06
    0
    Var a, r: integer; begin read (a) ; r:=1; write (1) ; While ((2*r) <=a) do begin r:=2*r; write (' ', r) ; end; readln; readln end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания. Операцией возведения в степень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа на питоне, помогите) По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания. Операцией возведения в степень пользоваться нельзя! Входные данные Вводится натуральное число.
Ответы (1)
По данному натуральному числу N найдите наибольшую целую степень двойки, не превосходящую N. Выведите показатель степени и саму степень. Операцией возведения в степень пользоваться нельзя! Phyton Цикл While
Ответы (1)
Помогите составить программу на языке Паскаль! Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
Ответы (1)
Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
Ответы (1)
По данному целому числу N распечатайте все квадраты натуральных чисел, не превосходящие N, в порядке возрастания. Phyton Цикл While
Ответы (1)