Задать вопрос
30 ноября, 02:36

1. Составить программу, распечатывающую все трехзначные числа, у которых цифры расположены в порядке возрастания.

2. Найти произведение всех нечетных чисел, вводимых с клавиатуры. Признак окончания ввода цифра 0.

3. Вывести все квадраты натуральных чисел, не превосходящие данного числа N.

+5
Ответы (1)
  1. 30 ноября, 03:43
    -1
    Var a, b, c:byte;

    Begin

    For a: = 1 to 9 do

    For b: = a+1 to 9 do

    For c: = b+1 to 9 do

    Write (a, b, c,' ')

    End.

    Var

    P:real;

    A:integer;

    Begin

    P:=1;

    Repeat

    Read (A) ;

    if A mod 2 0 then P:=P*A;

    Until A = 0;

    WriteLn ('P = ', P)

    End.

    Var

    N:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    For N: = 1 to N do

    Write (N*N,' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составить программу, распечатывающую все трехзначные числа, у которых цифры расположены в порядке возрастания. 2. Найти произведение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Составьте программу для решения Составьте программу для решения следующей задачи с использование цикла с предусловием: "Выведите все точные квадраты натуральных чисел, не превосходящие данного числа n".
Ответы (1)