Задать вопрос
14 февраля, 07:51

Напиши программу: Можно ли на листе бумаги, со сторонами x см и у см, разместить прямоугольный треугольник с катетами a см и b см, параллельными краям листа.

+1
Ответы (1)
  1. 14 февраля, 11:51
    0
    Думаю, что вы пишете программы на Паскале. Я в нём не очень силён, но попытаюсь решить:

    program name;

    var x, y, a, b: real;

    begin

    write ('Введите x, y, a, b: ') ;

    readln (x, y, a, b) ;

    if (x > a) then begin

    if (y > b) then begin

    write ('Треугольник со сторонами ', a) ;

    write (' и ', b, ' поместится на листе бумаги.') ;

    end;

    else writeln ('Треугольник не поместится на листе бумаги') ;

    else writeln ('Треугольник не поместится на листе бумаги') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напиши программу: Можно ли на листе бумаги, со сторонами x см и у см, разместить прямоугольный треугольник с катетами a см и b см, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Наташа, Валя, Маша, Галя и Лена вырезали из бумаги разные фигуры. Кто-то вырезал круг из бумаги в клетку, кто-то круг из бумаги в линейку, кто-то квадрат из бумаги в клетку, кто-то квадрат из бумаги в линейку, кто-то флажок из белой бумаги.
Ответы (2)
Квадрат, круг, ромб, треугольник вырезаны из белой, синей, красной и зеленой бумаги. Известно, что круг не белый и не зеленый; синяя фигура лежит между ромбом и красной фигурой; треугольник не синий и не зеленый;
Ответы (1)
Дан прямоугольный треугольник с катетами a и b. найти гипотенузу c Составить программу (информатика)
Ответы (1)
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
Укажите, какие из высказываний истинны, какие - ложны, а какие относятся к числу тех, истинность которых трудно или невозможно установить: а) "параллелограмм - это четырёхугольник с параллельными и равными противоположными сторонами";
Ответы (1)