Задать вопрос
19 августа, 16:25

Вычислить площадь круга радиус R которого меняется от А до В с шагом H.

сделать задачу паскалем

+5
Ответы (1)
  1. 19 августа, 19:50
    0
    Var a, b, h, r:real; i:integer;

    begin

    write ('a, b, h: ') ;

    readln (a, b, h) ;

    for i:=0 to round ((b-a) / h) do

    begin

    r:=a+i*h;

    writeln (r:4:1, pi*r*r:8:3) ;

    end;

    end.

    Пример:

    a, b, h: 2 3 0.2

    2.0 12.566

    2.2 15.205

    2.4 18.096

    2.6 21.237

    2.8 24.630

    3.0 28.274
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить площадь круга радиус R которого меняется от А до В с шагом H. сделать задачу паскалем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Каждый из 35 участников олимпиады по программированию владеет Паскалем, Бейсиком или двумя языками сразу. В анкете 25 человек указали владения Паскалем, А 22 - Бейсиком. Сколько участников программируют только на Паскале?
Ответы (2)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Помогите с Паскалем!) 1) Рассчитать площадь круга. Радиус вводится во время программы 2) Рассчитать площадь кольца. Данные вводятся во время выполнения программы. 3) С клавиатурой вводиться 5 чисел.
Ответы (1)
На языке программирования Python напишите программу, которая определяет, какой круг из трех больше, если известно, что R1 - радиус 1-го круга, R2 - радиус 2-го круга, R3 - радиус третьего круга.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)