Задать вопрос
23 декабря, 10:24

Составьте программы для решения следующих задач.

1. Определить площадь и периметр прямоугольника, если известны длина и ширина.

2. Определить размер сдачи, если известны количество имеющихся денег и стоимость покупки.

3. Определить стоимость проезда, если известны расстояние и стоимость проезда 1 километра.

4. Определить стоимость покупки, если известны цена товара и количество купленных килограмм.

5. Определить объём в литрах, если известен объём в баррелях. (1 баррель = 159 литров).

+2
Ответы (1)
  1. 23 декабря, 12:43
    0
    Var A, B:real;

    Begin

    //1

    Write ('Длина = ') ; ReadLn (A) ;

    Write ('Ширина = ') ; ReadLn (B) ;

    WriteLn ('S = ', A*B) ;

    WriteLn ('P = ',2 * (A+B)) ;

    //2

    WriteLn;

    Write ('Кол-во денег: ') ; ReadLn (A) ;

    Write ('Стоимость покупки: ') ; ReadLn (B) ;

    WriteLn ('Сдача: ', A-B) ;

    //3

    WriteLn;

    Write ('Расстояние: ') ; ReadLn (A) ;

    Write ('Стоимость проезда 1 км: ') ; ReadLn (B) ;

    WriteLn ('Стоимость проезда ', A,' км: ', A*B) ;

    //4

    WriteLn;

    Write ('Цена товара: ') ; ReadLn (A) ;

    Write ('Вес покупки: ') ; ReadLn (B) ;

    WriteLn ('Цена покупки: ', A*B) ;

    //5

    WriteLn;

    Write ('Объём в баррелях: ') ; ReadLn (A) ;

    WriteLn ('Объём в литрах: ', A*159) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программы для решения следующих задач. 1. Определить площадь и периметр прямоугольника, если известны длина и ширина. 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу Паскаль АВС. Определить размер сдачи, если известны количество имеющихся денег и стоимость покупки.
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту. Задача 1:Написать программу вычисления площади поверхности параллелепипеда. S=2 * (A*B+B*C+C*A) Введите данные А=9, В=7.
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
составьте программу в паскале, определяющую s - стоимость партии товара, состоящей из n единиц, если цена каждой единицы товара - c результат должен быть показан фарзой: Стоимость общей партии товара равна ... руб.
Ответы (1)