Задать вопрос
8 июля, 20:06

В массиве 10 элементов определить произведение чисел, попадающие в интервал от 10 до 20

+2
Ответы (1)
  1. 8 июля, 20:50
    0
    Program n1;

    const n=10;

    var a: array [1 ... n] of integer;

    i, P: integer;

    begin

    P:=1;

    for i:=1 to n do readln (a[i]) ;

    for i:=1 to n do

    begin

    if (a>=10) and (a<=20) then P:=P*a[i];

    end;

    writeln (P) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве 10 элементов определить произведение чисел, попадающие в интервал от 10 до 20 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить: количество элементов, которые меньше 7.
Ответы (1)
1. В массиве чисел с1, с2, ..., с 60 найти количество нулей стоящих на местах, кратных 4 т. е. среди чисел с4, с8, ..., с60. 2. В массиве чисел с1, с2, ..., с40 найти количество чисел, попавших в интервал [а, в]
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
Дан одномерный массив из n элементов в интервале [0,50] найти количество элементов попадающих в интервал [0,25] и количество элементов попадающих в интервал[40,50] (через процедуру)
Ответы (1)