Задать вопрос
15 мая, 17:01

Else информатика

Задача

Разработать диалоговое программу которая спрашивает имя пользователя и его возраст и определяет в какой вековой категории он относится.

От 1 до 10 лет - ребёнок

От 11 до 15 лет - подросток

От 16 до 20-юноша (девушка)

От 21 до 30 - молодой человек

Больше 31 - взрослый

+4
Ответы (1)
  1. 15 мая, 19:51
    0
    Program pr1;

    Var

    Age:integer;

    Name:char;

    Begin

    Writeln ('Enter your name') ;

    Readln (name) ;

    Writeln ('Enter your age') ;

    Readln (age) ;

    If ((age>=1) and (age<=10)) then

    Writeln (name,', ', age,' years old, kid)

    Else

    If ((age>=11) and (age<=15)) then

    Writeln (name,', ', age,' years old, teenager)

    Else

    If ((age>=16) and (age<=20)) then

    Writeln (name,', ', age,' years old, man/girl)

    Else

    If ((age>=21) and (age<=30)) then

    Writeln (name,', ', age,' years old, young human)

    Else

    If ((age>=31) then

    Writeln (name,', ', age,' years old, adult)

    Else

    ('Error 404') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Else информатика Задача Разработать диалоговое программу которая спрашивает имя пользователя и его возраст и определяет в какой вековой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)
1. Написать программу, которая запрашивает возраст человека, а затем, если возраст меньше 14 лет выводит на экран: "У вас пока нет паспорта", если возраст больше 14 лет выводит на экран: "У вас уже есть паспорт", а если возраст равен 14 годам,
Ответы (1)