Задать вопрос
23 февраля, 21:47

Решить задачу. Нужна программа на Паскале

проверить трехзначное число на четность и найти сумму его цифр если оно четное и произведение его числа если оно нечетное

+4
Ответы (1)
  1. 24 февраля, 01:16
    0
    Program n1;

    var a, pr: integer;

    begin

    readln (a) ;

    if (a mod 2=0) then write ((a mod 10) + (a mod 100 div 10) + (a div 100)) else

    write ((a mod 10) * (a mod 100 div 10) * (a div 100)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу. Нужна программа на Паскале проверить трехзначное число на четность и найти сумму его цифр если оно четное и произведение его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
даны числа 400, 121, 93,80, 4. прочитай правила и запиши на каждом листке. если число нечётное то его записывают на листке с подписью дик если число нечётное и трехзначное то его записывают на листке с подписью ник если число четное или трехзначное
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Введите с клавиатуры целое число в диапазоне 1-999. а) Определите количество знаков в числе; б) Определите четность числа; в) Выведите описание числа, например,"нечетное однозначное число","четное двухзначное число" и тд.
Ответы (1)