Задать вопрос
20 января, 09:41

Составить блок-схему и программу для решения задачи.

Дан одномерный массив С, состоящий из 11 целых чисел, принадлежащих отрезку [0; 25]. Элементы массива вывести в строчку через пробел. Найти количество нечетных элементов массива.

+3
Ответы (1)
  1. 20 января, 10:48
    0
    Program n1;

    const n=11;

    var c: array [1 ... n] of integer;

    i, k: integer;

    begin

    randomize;

    k:=0;

    for i:=1 to n do c[i]:=random (25) ;

    for i:=1 to n do write (c[i],' ') ;

    writeln;

    for i:=1 to n do if c[i] mod 20 then k:=k+1;

    writeln ('кол-во нечетных: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить блок-схему и программу для решения задачи. Дан одномерный массив С, состоящий из 11 целых чисел, принадлежащих отрезку [0; 25]. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)