Задать вопрос
14 февраля, 06:34

Найти сумму целых чисел от 1 до n кратных одновременно 3 и 6 постусловным циклом помогите написатт программу на паскале

+5
Ответы (1)
  1. 14 февраля, 07:09
    0
    6=2*3, поэтому если число кратно 6, то оно кратно и 3.

    Целые числа, начиная от 1 - это натуральные числа. Первое натуральное число, кратное 6, это 6. Следующее натуральное число, кратное 6, будет на 6 больше и т. д., т. е. образуется ряд 6,12,18, 24, ...

    var

    i, n, s:integer;

    begin

    Write ('n=') ; Read (n) ;

    s:=0; i:=6;

    repeat

    s:=s+i;

    i:=i+6;

    until i>n;

    Writeln ('S=', s)

    end.

    Пример

    n=100

    S=816
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму целых чисел от 1 до n кратных одновременно 3 и 6 постусловным циклом помогите написатт программу на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100). Нужно составить 1 - с циклом с пред условием, 2 - с циклом с пост условием
Ответы (1)
Написать программу в Паскале. Используя операторы цикла и условия, написать программу, которая из введенных N чисел: 1) Находит и выводит на экран все двухзначные числа, кратные 10 (с циклом mod). 2) Найти сумму всех чисел больше 10.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)