Задать вопрос
12 сентября, 15:56

Напишите программу на языке Паскаль!

С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе.

+2
Ответы (1)
  1. 12 сентября, 18:53
    0
    Var

    a, b, c, sum: integer;

    function min (x, y: integer) : integer;

    begin

    if (x > y) then result : = y

    else result : = x;

    end;

    begin

    sum : = 0;

    read (a, b, c) ;

    a : = min (a, min (b, c)) ;

    while a > 0 do

    begin

    if (a mod 10 mod 2 0) then sum : = sum + a mod 10;

    a : = a div 10;

    end;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Паскаль! С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)