Задать вопрос
18 марта, 13:01

Program ca;

var

p, i: integer;

begin

i : = 3;

p : = 1;

while i < = 23 do

begin

p : = p * i;

i : = i + 2;

end;

writeln ('p = ', p) ;

end.

Говорит что арифметич. переполнение

2 задания) Задан массив А [1 ... 5]. Составить программу, которая выводит на экран элементы массива в обратном порядке.

3) задания: Задан массив А [1 ... 15]. Составить программу, которая выводит разность суммы элементов массива чётными индексами и элементов массива с нечётными индексами

+5
Ответы (1)
  1. 18 марта, 15:50
    0
    Второе:

    program o;

    var A:array[1 ... 5] of integer; i:integer;

    begin;

    for i:=1 to 5 do readln (A[i]) ;

    for i:=5 downto 1 do writeln (A[i])

    end.

    Третье:

    program p;

    var A:array[1 ... 15] of integer; i, sum1, sum2, res:integer;

    begin;

    for i:=1 to 15 do read (A[i]) ;

    for i:=1 to 15 do

    if i mod 2=0 then sum1:=sum1+A[i] else sum2:=sum2+A[i];

    res:=sum1-sum2;

    write (res) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Program ca; var p, i: integer; begin i : = 3; p : = 1; while i < = 23 do begin p : = p * i; i : = i + 2; end; writeln ('p = ', p) ; end. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Укажите области видимости в программе: Program P; Var x: integer; Procedure P1; Var y: integer; Begin P2; End; Procedure P2; Var z: integer; Begin {Тело процедуры} End; Procedure P3; Var m: integer; Begin P1; End; Begin {Тело основной программы}P3;
Ответы (1)
Объясните строчку (c:=10*c+a mod 10; a : = a div 10;) program pr36; function qwer (var a, b: integer) : integer; var c: integer; begin c:=0; while a > 0 do begin c:=10*c+a mod 10; a : = a div 10; end; qwer: = c; end; var a, b: integer;
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)