Задать вопрос
13 сентября, 13:08

Рассчитать значение, определив и использовав необходимую функцию.

N вводится с клавиатуры.

y = (1+sin (1)) / 3 + (3+sin (3)) / 3 + ... + ((2*N-1) + sin (2*n-1)) / 3

PascalABC

+2
Ответы (1)
  1. 13 сентября, 15:34
    0
    Var y:real; n, i:integer;

    function f (x:real) : real;

    begin

    f: = (x+sin (x)) / 3;

    end;

    begin

    write ('n = ') ;

    readln (n) ;

    y:=0;

    for i:=1 to n do y:=y+f (2*i-1) ;

    writeln ('y = ', y) ;

    end.

    Пример:

    n = 5

    y = 8.69759060072172
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Рассчитать значение, определив и использовав необходимую функцию. N вводится с клавиатуры. y = (1+sin (1)) / 3 + (3+sin (3)) / 3 + ... + ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Всё сделать в программе PascalABC Задача №1 С клавиатуры вводится число n. Заполнить n элементов массива числами 2,4,8,16 ... и вывести массив. В массиве может находить не более 100 элементов. Задача №2 С клавиатуры вводится число n.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Введите с клавиатуры массив k3{n} определите сумму и количество положительных элементов массива. n вводится с клавиатуры. 0 Написать в pascalABC
Ответы (1)