Задать вопрос
13 августа, 00:12

Найти количество максимальных элементов одномерного массива (паскаль)

+2
Ответы (1)
  1. 13 августа, 03:57
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, Max, k:integer;

    Begin

    Write ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ')

    End;

    WriteLn;

    k:=0;

    Max:=A[1];

    For i: = 2 to N do

    if A[i]>Max then

    Begin

    Max:=A[i];

    k:=1;

    End

    else if A[i]=Max then k:=k+1;

    WriteLn ('Max = ', Max) ;

    WriteLn ('Кол-во максимумов: ', k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество максимальных элементов одномерного массива (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)