Задать вопрос
27 сентября, 16:30

Подсчитать количество положительных элементов в каждом столбце матрицы размером МхN, элементы которой вводятся с клавиатуры.

+2
Ответы (1)
  1. 27 сентября, 17:29
    0
    Const

    M = 3;

    N = 4;

    Var

    A:array[1 ... M, 1 ... N] of integer;

    i, j, k:integer;

    Begin

    WriteLn ('Введите матрицу A (', M,',', N,') : ') ;

    For i: = 1 to M do

    For j: = 1 to N do

    Read (A[i, j]) ;

    WriteLn ('Количества положительных элементов в столбцах:') ;

    For j: = 1 to N do

    Begin

    k:=0;

    For i: = 1 to M do

    if A[i, j] > 0 then k:=k+1;

    Write (k,' ')

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество положительных элементов в каждом столбце матрицы размером МхN, элементы которой вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужна прога в паскале. Даю 20 б Подсчитать количество положительных элементов в каждом столбце матрицы размером МхN. элементы которой задаются с помощью датчика случайных чисел на интервале [-30; 40].
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Помогите с кодом по паскалю.→Нужно чтобы ответ который показывается было написано первый столбец столько положительных чисел а если нет положительных чисел в столбце то писало нет положительных чисел в этом столбце←Столбцы пронумеровать Изначально
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)