Задать вопрос
17 ноября, 16:59

С клавиатуры ваодится m целых чисел. Подсчитать сколько из них отрицательные и все нечётные перемножить

+4
Ответы (1)
  1. 17 ноября, 19:06
    0
    Program n1;

    var m, k, p, a, i: integer;

    begin

    readln (m) ;

    k:=0;

    p:=1;

    for i:=1 to m do

    begin

    readln (a) ;

    if a<0 then k:=k+1;

    if a mod 20 then p:=p*a;

    end;

    writeln (k) ;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры ваодится m целых чисел. Подсчитать сколько из них отрицательные и все нечётные перемножить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Дан массив целых чисел, состоящий из 25 элементов. заполните его с клавиатуры. Найти: сумму элементов имеющих нечётные индексы; подсчитать количество элементов массива, значения которых больше заданного числа А и кратны 5
Ответы (1)
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)