Задать вопрос
10 июня, 06:32

Дано 3 х значное число. Найти сумму и произведение всех чисел

+5
Ответы (1)
  1. 10 июня, 10:25
    0
    Var a, e, z, y, x:integer;

    Begin

    Writeln ('Введите трехзначное число') ;

    Readln (a) ;

    x:=a div 100;

    y: = (a-x*100) div 10;

    z:=a-y*10-x*100;

    e:=x+y+z;

    writeln ('Сумма чисел ', x,' ', y,' и ', z,' равна ', e,'.') ;

    end.

    p. s.

    a-трехзначное число

    e-сумма чисел

    x, y и z - первое, второе и третье число соответственно.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 3 х значное число. Найти сумму и произведение всех чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)