Задать вопрос
11 августа, 23:58

С клавиатуры вводится строка. Заменить в ней слово dog на слово cat.

Pascal ABC

+5
Ответы (1)
  1. 12 августа, 01:41
    0
    Var

    S:string;

    i, k:integer;

    Begin

    k:=0;

    Write ('Введите строку: ') ; ReadLn (S) ;

    For i: = 1 to Length (S) - 2 do

    if S[i]='d' then

    if S[i+1]='o' then

    if S[i+2]='g' then

    Begin

    S[i]:='c';

    S[i+1]:='a';

    S[i+2]:='t';

    End;

    WriteLn ('Новая строка: ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится строка. Заменить в ней слово dog на слово cat. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Я никогда не подружусь с этой темой ... 1. С клавиатуры вводится 7 целых чисел. Найти сумму всех нечетных среди них. 2. С клавиатуры вводится 7 целых чисел. Найти произведение чисел кратных 7. (Информатика. Тема: Pascal ABC. 8 класс)
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)