Задать вопрос
16 августа, 06:15

Напишите процедуру которая находит корни уравнения ax2 + bx + c = 0.

+1
Ответы (1)
  1. 16 августа, 10:07
    0
    Program n1;

    var x, y, z: real;

    procedure kvur (a, b, c: real) ;

    var D: real;

    begin

    D:=b*b-4*a*c;

    writeln ('x1=', (-b+sqrt (D)) / 2*a) ;

    writeln ('x2=', (-b-sqrt (D)) / 2*a) ;

    end;

    begin

    write ('a=') ;

    readln (x) ;

    write ('b=') ;

    readln (y) ;

    write ('c=') ;

    readln (z) ;

    kvur (x, y, z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите процедуру которая находит корни уравнения ax2 + bx + c = 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Описать процедуру SumDigit (N, S), находящую сумму цифр S целого числа N (N - входной, S - выходной параметр). Используя эту процедуру, найти суммы цифр пяти данных чисел.
Ответы (1)