Задать вопрос
11 августа, 18:39

Найти положительные числа из 10 натуральных чисел. Паскаль!

+3
Ответы (1)
  1. 11 августа, 20:56
    0
    Var a: array [1 ... 10] of real;

    begin

    writeln ('Введите 10 натуральных чисел') ;

    for i:=1 to 10 do read (a[i]) ;

    for i:=1 to 10 do

    if a[i] > 0 then writeln (a[i])

    end.

    Программа просит пользователя ввести 10 натуральных чисел. Для этого используется оператор read в первом цикле.

    Во втором цикле проверяется каждое из 10 чисел. Если оно положительное, т. е. больше 0, оно выводится на экран. Затем программа завершает работу.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти положительные числа из 10 натуральных чисел. Паскаль! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Даны числа M и N. Составить программу следующего содержания: если числа положительные и их сумма больше 100, вывести отношение числа M к числу N. Если числа положительные и их сумма не больше 100, то произведение чисел M и N.
Ответы (1)