Задать вопрос
8 июля, 13:58

Нужна помощь)) если не сложно с коментариями

Описать функцию Transform (n), которая "припишет" к числу n по единичке в начале и в конце. Обратиться к функции со значениями 23, 234, 2345.

+3
Ответы (1)
  1. 8 июля, 15:44
    0
    Function Transform (n:longint) : longint;

    Var

    k, B:longint;

    Begin

    B:=n;

    k:=1;

    While B 0 do

    Begin

    k:=k*10;

    WriteLn ('k = ', k) ;

    B:=B div 10;

    End;

    if n > = 0 then

    Begin

    WriteLn ('n: = k + n = ', k,' + ', n,' = ', n+k) ;

    WriteLn ('n: = 10*n + 1 = ',10 * (k+n),' + ',1,' = ', (k+n) * 10+1) ;

    Transform: = (k+n) * 10+1

    End;

    End;

    Var

    A:longint;

    Begin

    Write ('Введите целое число: ') ; ReadLn (A) ;

    WriteLn (Transform (A))

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна помощь)) если не сложно с коментариями Описать функцию Transform (n), которая "припишет" к числу n по единичке в начале и в конце. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Python Middle: 1. Напиcать функцию, которая возвращает частное двух чисел, полученных в качестве аргументов. 2. Напиcать функцию, которая возвращает минимальное из двух чисел, полученных в качестве аргументов. 3.
Ответы (1)