Задать вопрос
7 июля, 16:32

Это в pascal abc. Дано вещественное число X и целое число N (> 0). Найти значение выражения X - X3 / (3!) + X5 / (5!) - ... + (-1) N·X2·N+1 / ((2·N+1) !) (N! = 1·2· ...·N).

+3
Ответы (1)
  1. 7 июля, 17:34
    0
    Var x, s, d:real; k, n:integer;

    begin

    read (x, n) ;

    s : = x;

    d : = x;

    for k : = 1 to n do

    begin

    d : = - d*sqr (x) / (2*k) / (2*k+1) ;

    s : = s + d;

    end;

    writeln (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Это в pascal abc. Дано вещественное число X и целое число N (> 0). Найти значение выражения X - X3 / (3!) + X5 / (5!) - ... + (-1) N·X2·N+1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal Дано вещественное число X и целое число N (> 0). Найти значение выражения 1 + X + X^2 / (2!) + ... + X^N / (N!) (N! - факториал числа N). Полученное число является приближенным значением функции exp в точке X.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Какой тип будет иметь выражение при делении целого числа на вещественное? Вещественное или целое? Объясните почему.
Ответы (1)