Задать вопрос
9 июля, 03:18

Написать программу на языке Pascal. Даны действительные числа а₁, а₂, ..., а₂₀.

Вычислить их сумму.

+3
Ответы (1)
  1. 9 июля, 06:38
    0
    Const

    N = 20;

    Var

    A:array[1 ... N] of real;

    i:integer;

    S:real;

    Begin

    Randomize;

    S:=0;

    Write ('Исходный массив A (', N,') : ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random * (N*2+1) - N;

    Write (' ', A[i]:0:3) ;

    S:=S+A[i];

    End;

    WriteLn;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Pascal. Даны действительные числа а₁, а₂, ..., а₂₀. Вычислить их сумму. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)