Задать вопрос
11 апреля, 15:07

Заполнить массив на 30 целочисленных элементов псевдослучайными значениями от - 200 до 200, найти самое большое отрицательное число и самое маленькое положительное (Паскаль)

+3
Ответы (1)
  1. 11 апреля, 16:36
    0
    Program prog;

    Uses crt;

    var a: array [0 ... 29] of integer;

    max, min, i: integer;

    begin;

    clrscr;

    randomize;

    max:=-201;

    min:=201;

    for i:=0 to 29 do

    begin

    a[i]:=random (401) - 200;

    write (a[i],' ') ;

    if (a[i]>max) and (a[i]<0) then

    max:=a[i];

    if (a[i]0) then

    min:=a[i];

    end;

    writeln;

    writeln;

    writeln ('max neg = ', max) ;

    writeln ('min pos = ', min) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить массив на 30 целочисленных элементов псевдослучайными значениями от - 200 до 200, найти самое большое отрицательное число и самое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заполнить массив на 200 элементов псевдослучайными числами (целыми) от 20 до 80. Вывести полученный массив на экран, затем определить среднее арифметическое элементов, больших чем 50
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)