Задать вопрос
25 марта, 20:26

Известна сумма денег S, имеющаяся у покупателя и стоимость одной единицы товара Z. Сколько единиц товара сможет купить покупатель и какова его сдача C?

+3
Ответы (1)
  1. 25 марта, 22:39
    0
    var s, z, k, c:integer;

    begin

    write ('s = ') ;

    readln (s) ;

    write ('z = ') ;

    readln (z) ;

    k:=s div z;

    c:=s mod z;

    writeln ('Кол-во товара: ', k,', сдача: ', c) ;

    end.

    Пример:

    s = 120

    z = 50

    Кол-во товара: 2, сдача: 20
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известна сумма денег S, имеющаяся у покупателя и стоимость одной единицы товара Z. Сколько единиц товара сможет купить покупатель и какова ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат отпускает максимум N единиц товара. Известна стоимость одной единицы товара Z и сумма денег, имеющаяся у покупателя S. Сколько единиц товара может получить покупатель и какова сдача?
Ответы (1)
У прилавка магазина выстроилась очередь из N покупателей. Время обслуживания i-го покупателя равно ti. Определить время Ci пребывания i-го покупателя в очереди. Протестировать программу на следующих исходных данных: а) Номер покупателя - 5.
Ответы (1)
составьте программу в паскале, определяющую s - стоимость партии товара, состоящей из n единиц, если цена каждой единицы товара - c результат должен быть показан фарзой: Стоимость общей партии товара равна ... руб.
Ответы (1)
В паскале! Известно, что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб. Покупатель имеет S рублей. Напишите программу, которая определяет, хватит ли у покупателя средств на данную покупку?
Ответы (2)
Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения
Ответы (1)