Задать вопрос
24 сентября, 14:19

Дан массив вещественных чисел. Определить сколько раз встречается в массиве 0.

+1
Ответы (1)
  1. 24 сентября, 16:44
    0
    Const

    N = 33;

    Var

    A:array[1 ... N] of real;

    i, k:integer;

    Begin

    Randomize;

    k:=0;

    For i: = 1 to N do

    Begin

    if random (2) = 1 then A[i]:=random*N

    else A[i]:=0;

    Write (A[i]:0:3,' ') ;

    if A[i] = 0 then k:=k+1

    End;

    WriteLn;

    WriteLn ('Количество нулей в массиве: ', k) ;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив вещественных чисел. Определить сколько раз встречается в массиве 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k. №2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)