Задать вопрос
7 сентября, 06:13

В массиве найти сумму и кол-во элементов между первым и последним положительными элементами. (паскаль)

+5
Ответы (1)
  1. 7 сентября, 10:00
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, k1, k2, s:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) - 25;

    write (a[i]:4) ;

    end;

    writeln;

    for i:=1 to n do

    begin

    if a[i]>0 then k2:=i;

    if a[n+1-i]>0 then k1:=n+1-i;

    end;

    writeln ('k1 = ', k1,' k2 = ', k2) ;

    s:=0;

    for i:=k1+1 to k2-1 do s:=s+a[i];

    writeln ('s = ', s,' k = ', k2-k1-1) ;

    end.

    Пример:

    Массив A:

    -9 - 4 - 22 - 1 19 - 23 - 24 16 - 12 - 25

    k1 = 5 k2 = 8

    s = - 47 k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве найти сумму и кол-во элементов между первым и последним положительными элементами. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n вещественных элементов, вычислить: 1) Максимальный по модулю элемент массива 2) Сумму элементов массива, расположенных между первым и вторым положительными элементами.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)