Задать вопрос
24 сентября, 18:47

Написать функцию нахождения кол-ва цифр через рекурсию. Паскаль. Рекурсия.

Через функцию.

+4
Ответы (1)
  1. 24 сентября, 19:37
    0
    Var a:integer;

    function k (n:integer) : integer;

    begin

    if n<10

    then k:=1

    else k:=k (n div 10) + 1;

    end;

    begin

    write ('a = ') ;

    readln (a) ;

    writeln ('Количество цифр = ', k (a)) ;

    end.

    Пример:

    a = 134652

    Количество цифр = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать функцию нахождения кол-ва цифр через рекурсию. Паскаль. Рекурсия. Через функцию. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Pascal, используя рекурсию: Дан набор символов, оканчивающихся пробелом (короче это слово), Вывести символы в обратном порядке, используя рекурсию.
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Дано натуральное число n. Выведите все числа от 1 до n. на паскаль. цикл не использовать. рекурсия
Ответы (1)