Задать вопрос
1 апреля, 03:00

Дано число типа byte. Проверить, является ли палиндромом его двоичное

представление с учетом того, что сохранены старшие нули. Пример таких чисел: 102 (т. к. 102 =

0110 01102, а это палиндром), 129 (129 = 1000 00012) и т. д.

+4
Ответы (2)
  1. 1 апреля, 03:42
    0
    var a: array of integer;

    var i: byte;

    var b: boolean;

    begin

    b:=true;

    setlength (a, 8) ;

    var n:=0;

    writeln ('Введите число: ') ;

    readln (i) ;

    var d:=i;

    while i0 do

    begin

    a[n]:=i mod 2;

    i:=i div 2;

    inc (n) ;

    end;

    setlength (a, n) ;

    for i:=0 to n-1 do

    begin

    if n=0 then

    begin

    write (0) ;

    break;

    end;

    swap (a[i], a[n-1]) ;

    write (a[i]) ;

    end;

    for i:=1 to n-1 do

    begin

    if n=0 then

    break;

    if a[i-1]a[i] then

    begin

    b:=false;

    break;

    end;

    end;

    if (b=false) then

    write (' = ', d,' это не палиндром')

    else

    write (' = ', d,' это палиндром') ;

    end.
  2. 1 апреля, 06:17
    0
    Program p_3;

    var

    n, a, b, c, d: byte;

    begin

    readln (n) ;

    a : = n mod 2;

    n : = n div 2;

    b : = n mod 2;

    n : = n div 2;

    c : = n mod 2;

    n : = n div 2;

    d : = n mod 2;

    n : = n div 2;

    a : = 8 * a + 4 * b + 2 * c + d;

    writeln (n = a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано число типа byte. Проверить, является ли палиндромом его двоичное представление с учетом того, что сохранены старшие нули. Пример таких ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Преобразуйте следующее двоичное число в восьмеричное: 10011 2) Преобразуйте следующее двоичное число в десятеричное: 101100 3) Преобразуйте следующее двоичное число в шестнадцатеричное: 1011000111 4) Преобразуйте следующее восьмеричное число в
Ответы (1)
1) Преобразуйте слудующее двоичное число в восьмеричное: 10011000. 2) Преобразуйте слудующее двоичное число в десятичное: 11101101. 3) Преобразуйте слудующее двоичное число в шестнадцатеричное: 1011111110.
Ответы (2)
1. Укажите размер типа Byte в байтах: A) 1; B) 2; C) 3; D) 4. 2. Какой из перечисленных типов является символьным типом данных? A) byte; B) char; C) boolean; D) integer. 3.
Ответы (1)
Переведете мне с языка паскаля на язык C++ program Integer3; var byte, kilobyte: Integer; begin Write ('Введите размер файла в байтах: ') ; Readln (byte) ; kilobyte:=byte div 1024; Writeln ('Данный файл занимает ', kilobyte,' полных килобайт.
Ответы (1)
Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)