Задать вопрос
17 января, 02:17

Составьте программу, отыскивающую наименьший общий составной делитель натуральных чисел N и М. (обязательно использование подпрограмм)

+1
Ответы (2)
  1. 17 января, 02:55
    0
    Program pr1;

    Var m, n, i, j:integer;

    Function isitsimple (x:integer) : boolean;

    Var i:integer;

    Begin

    isitsimple:=false;

    For i:=2 to x-1 do

    if x mod i=0 then isitsimple:=true;

    End;

    Begin

    Writeln ('input m') ;

    Readln (m) ;

    Writeln ('input n') ;

    Readln (n) ;

    If m>n then j:=m;

    For i:=1 to j do

    if (m mod i=0) and (n mod i=0) then

    If isitsimple (i) then

    Begin

    writeln ('NOD: ', i) ;

    Break;

    End;

    End.
  2. 17 января, 05:24
    0
    Var n, m, k, i: integer; f:boolean;

    Function s (a:integer) : boolean;

    Var i:integer;

    Begin

    s:=false;

    For i:=2 to a div 2 do

    if a mod i=0 then s:=true;

    End;

    Begin

    Write ('n = ') ;

    Readln (n) ;

    Write ('m = ') ;

    Readln (m) ;

    If m
    i:=1; f:=s (i) ;

    while (i
    begin

    i:=i+1;

    if (m mod i=0) and (n mod i=0) then f:=s (i) ;

    end;

    if f then writeln ('НОД = ', i) else writeln ('Нет требуемого делителя') ;

    End.

    Пример:

    n = 42

    m = 105

    НОД = 21
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, отыскивающую наименьший общий составной делитель натуральных чисел N и М. (обязательно использование подпрограмм) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) такое составной оператор? В каких случаях составной оператор используется в операторе ветвления? 2) составьте программу сортировки по возрастанию значений трех переменных: А Б С в системе паскаль
Ответы (1)
Составьте программу для решения Составьте программу для решения следующей задачи с использование цикла с предусловием: "Выведите все точные квадраты натуральных чисел, не превосходящие данного числа n".
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Что такое составной оператор? в каких случиях составной оператор используется в операторе ветвления
Ответы (1)