Задать вопрос
27 сентября, 15:45

Два неразлучных товарища решили вместе зарабатывать на жизнь и жить дружно всю жизнь до самой смерти. Устроившись на хорошую работу (целое случайное число до 1000 р. В день) решили все деньги, полученные ими в день, делить поровну, а если число получиться нечетное, то складывать остаток от деления их, опять таки, общую свинью-копилку. Составьте программу

+1
Ответы (1)
  1. 27 сентября, 17:59
    0
    Var a, b: integer

    c, e:longint;

    begin

    write ('введите количество прожитых дней друзьями-->') ;

    readln (b) ;

    for i:=b downto 0 do begin

    write ('сколько денег они заработали в этот день-->') ;

    readln (a) ;

    if a mod 2 = 0 then e: = a/2

    else c:=a;

    end;

    write ('заработал каждый из них за всю жизнь-->', e) ;

    write ('то что они смогли накопить за всю жизнь-->', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Два неразлучных товарища решили вместе зарабатывать на жизнь и жить дружно всю жизнь до самой смерти. Устроившись на хорошую работу (целое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)
Дано натуральное число N. Если оно делиться на 4, вывести на экран ответ N=4*k (где k - соответствующее частное; если остаток от деления на 4 равен6 1, то N = 4k+1; если остаток от деления на 4 равен 2, то N = 4k+2;
Ответы (1)