Задать вопрос
27 июня, 17:10

Составить программу, которая находит и выводит сумму всех натуральных чисел из отрезка от А до В, кратных 5 и 13 (А и В водятся с клавиатуры)

+1
Ответы (1)
  1. 27 июня, 18:21
    0
    Uses crt;

    var

    A, B, i, s:integer;

    begin

    writeln ('A=') ; readln (A) ;

    writeln ('B = ') ; readln (B) ;

    s:=0;

    for i:=A to B do begin

    if ((i mod 5=0) or (i mod 13=0)) then s:=s+i;

    end;

    writeln ('Сумма чисел, кратных 5 и 13, от ', A,' до ', B,' = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая находит и выводит сумму всех натуральных чисел из отрезка от А до В, кратных 5 и 13 (А и В водятся с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)