Задать вопрос
19 января, 11:11

PascalABC

дано целое число. Верно ли, что в числе нет 5?

+4
Ответы (2)
  1. 19 января, 11:34
    0
    Program n1;

    var a: integer;

    function is5 (var x: integer) : boolean;

    begin

    is5:=false;

    while (x0) do begin

    if (x mod 10=5) then

    begin

    is5:=true;

    break;

    end;

    x : = x div 10;

    end;

    end;

    begin

    readln (a) ;

    if is5 (a) then write ('есть')

    else write ('нет') ;

    end.
  2. 19 января, 14:23
    0
    Var A:integer;

    B:boolean;

    Begin

    B:=true;

    Write ('A = ') ; Read (A) ;

    While A>0 do

    Begin

    if A mod 10 = 5 then B:=false;

    A:=A div 10;

    End;

    if B then WriteLn ('Верно')

    else WriteLn ('Не верно')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «PascalABC дано целое число. Верно ли, что в числе нет 5? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)
Дано целое число. Проверить: является ли данное число отрицательным двузначным числом кратным десяти. В PascalABC
Ответы (1)
1). Дано целое число Х. Составьте программу которая выясняет верно ли что 0 больше или равно Х и больше 1. 2). Дано целое число П. Составьте программу которая выясняет является им значение П кратное 3.
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)