Задать вопрос
2 ноября, 18:39

Дан массив размера N. Вывести вначале его элементы с четными индексами, а затем - с нечетными

+5
Ответы (1)
  1. 2 ноября, 20:49
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    Begin

    Randomize;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ')

    End;

    WriteLn;

    i:=1;

    While i < = N do

    Begin

    Write (A[i],' ') ;

    i:=i+2;

    End;

    WriteLn;

    i:=2;

    While i < = N do

    Begin

    Write (A[i],' ') ;

    i:=i+2;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив размера N. Вывести вначале его элементы с четными индексами, а затем - с нечетными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Составить программу которая выводит массив, где элементы с чётными индексами поменяются местами с нечётными индексами.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)