Задать вопрос
30 мая, 07:43

1!+2!+3! + ... + n!

нужно написать на Паскале, понять не могу

+5
Ответы (1)
  1. 30 мая, 10:29
    0
    var n: integer;

    k, s, m: int64;

    begin

    write ('n = ') ; readln (n) ;

    k:=1; s:=0; m:=1;

    repeat

    m:=m*k;

    s:=s+m;

    k:=k+1;

    until k>n;

    writeln ('сумма: ', s) ;

    end.

    n = 5

    сумма: 153
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1!+2!+3! + ... + n! нужно написать на Паскале, понять не могу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Как написать программу в паскале которая будит вычислять оценку за четверть / в паскале если можете распишете все решение
Ответы (1)
Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива Нужно в тетраде написать Нужно написать так, как в паскале
Ответы (1)
1) как можно описать в паскале массив в котором будут хранится значения численности населения Москвы к концу каждого года 20 века. 2) Вы приобрели котенка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)