Задать вопрос
5 ноября, 10:49

Ребята, хелп ((Не шарю вообще. Тема - циклы

1) Написать программу вычисления суммы:

S=1*2*3+2*3*4+3*4*5 + ... + 21*22*23

+1
Ответы (1)
  1. 5 ноября, 12:35
    0
    Var i, s:integer;

    begin

    s:=0;

    for i:=1 to 21 do s:=s+i * (i+1) * (i+2) ; writeln ('s = ', s) ;

    end.

    Результат:

    s = 63756
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребята, хелп ((Не шарю вообще. Тема - циклы 1) Написать программу вычисления суммы: S=1*2*3+2*3*4+3*4*5 + ... + 21*22*23 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Тема "Циклы" Составить программу для вычисления суммы всех двузначных чисел.
Ответы (1)
Тема:Pascal. Циклы 1) Составить программу подсчета суммы нечетных делителей, кратных трем, натурального числа N 2) Составить программу, вычисляющую x^n, где n-целое положительное число. 3) Одноклеточная амеба каждые 3 часа делится на 2 клетки.
Ответы (1)
5. Алгоритм, не реализующий обратную связь 1) может содержать циклы и ветвления 2) может содержать циклы 3) может быть только циклическим 4) может быть только линейным 5) может содержать ветвления 6) пропустить
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)