Задать вопрос
30 октября, 15:55

Как решить такую задачу в паскале?

Дано двузначное число. Найти сумму его цифр.

+5
Ответы (1)
  1. 30 октября, 18:13
    0
    var a, s:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    s:=a div 10+a mod 10;

    writeln ('s = ', s) ;

    end.

    Пример:

    a = 25

    s = 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как решить такую задачу в паскале? Дано двузначное число. Найти сумму его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)