Задать вопрос
25 июля, 13:20

Напишите программу в Pascal для этой задачи:

Найти среднее арифметическое и сумму последовательности положительных чисел

+3
Ответы (1)
  1. 25 июля, 16:06
    0
    Var a, sum, i : integer; s, x : string; sa : real;

    begin sum:=0; readln (s) ; for i:=1 to length (s) do begin x:=copy (s, i, 1) ; val (x, a) ; sum:=sum+a; end; sa:=sum / (length (s)) ; writeln ('сумма: ', sum) ; writeln ('среднее арифметическое: ', sa:4:2) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Pascal для этой задачи: Найти среднее арифметическое и сумму последовательности положительных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (2)