Задать вопрос
30 мая, 20:05

Определить число полученное выписыванием в обратном порядке цифр заданного целого трехзначного числа

+4
Ответы (1)
  1. 30 мая, 20:12
    0
    Var n, n1, m:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    n1:=abs (n) ;

    m: = (n1 mod 10) * 100 + (n1 div 10 mod 10) * 10 + (n1 div 100) ;

    if n<0 then m:=-m;

    writeln ('m = ', m) ;

    end.

    Пример:

    n = - 123

    m = - 321
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить число полученное выписыванием в обратном порядке цифр заданного целого трехзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое положительное трехзначное число. Напишите программу, позволяющую определить число, полученное выписыванием в обратном порядке цифр заданного трехзначного числа. Например: 123->321.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Ввести число N. Вывести число, получаемое выписыванием в обратном порядке цифр числа N. (Например, 1234, результат 4321). pascal цикл while или repeat
Ответы (2)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)