Задать вопрос
17 февраля, 04:17

В интервале от k1 до k2 найти количество простых чисел. Паскаль

+2
Ответы (1)
  1. 17 февраля, 07:12
    0
    Var k1, k2, k, i, m, j:integer;

    begin

    write ('k1, k2:') ;

    readln (k1, k2) ;

    k:=0;

    for i:=k1 to k2 do

    begin

    m:=0;

    for j:=2 to round (sqrt (i)) do

    if i mod j = 0 then m:=m+1;

    if m=0 then k:=k+1;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    k1, k2:10 100

    k = 21
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В интервале от k1 до k2 найти количество простых чисел. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Паскаль - массивы. Написать программу, которая считает среднее число шагов в двоичном поиске для массива из 32 элементов в интервале [0,100]. Для поиска использовать 1000 случайных чисел в этом же интервале.
Ответы (1)
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)