Задать вопрос
30 мая, 19:18

Паскаль.

есть n количество студентов и t время. блоха сидит на первом студенте. и за каждую секунду прыгает на следующего. программа должна вывести на каком студенте блоха окажется по окончании времени

+5
Ответы (1)
  1. 30 мая, 21:17
    0
    В общем, вот Вам программа на Console Aplication:

    var n, t, i, a:Integer;

    begin

    Writeln ('Vvedite kol-vo studentov') ;

    Readln (n) ;

    Writeln ('Vvedite kol-vo vremeni (sek) ') ;

    Readln (t) ;

    a:=1;

    for i:=1 to t do

    begin

    a:=a+1;

    if (a=n) then

    begin

    a:=0;

    end;

    if i=t then

    begin

    Writeln ('cherez ', (t), ' sek bloha bydet na ', (a), ' studente') ;

    end;

    end;

    Readln;

    end.

    Всё работает, проверял.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. есть n количество студентов и t время. блоха сидит на первом студенте. и за каждую секунду прыгает на следующего. программа должна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Ваня наблюдает за лягушкой. Изначально она сидит в точке 0 числовой прямой. Каждую секунду она прыгает на 1 вправо, пока не достигнет точки K. Затем она начинает каждую секунду прыгать на 1 влево, пока не вернется в точку 0, затем - опять вправо и т.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)