Задать вопрос
23 апреля, 23:35

Дана последовательность целых чисел, признаком конца которой служит 0. 0 не входит в последовательность. Найти среднеарифметическое элементов последовательности. Напишите программу

+4
Ответы (1)
  1. 24 апреля, 03:05
    0
    Program n1;

    var a, sum, k: integer;

    begin

    readln (a) ;

    sum:=0;

    k:=0;

    while a0 do

    begin

    sum:=sum+a;

    k:=k+1;

    readln (a) ;

    end;

    writeln (sum/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых чисел, признаком конца которой служит 0. 0 не входит в последовательность. Найти среднеарифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
По каналу связи передается последовательность положительных целых чисел, все числа не превышают 1000, их количество заранее неизвестно. Каждое число передается отдельно. Признаком конца передаваемой последовательности является число 0.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Признаком конца последовательности является ввод 0.
Ответы (1)